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Exporting MARC bibliographic records from OCLC is one of the many workflow options 

available to I-Share libraries.  Export functionality for Voyager requires copying records to a 

local file on the PC, then importing the records from that file through either the Cataloging client 

or the Acquisitions client.  Your library will have a number of options both for creating export 

files and for importing them to Voyager.  Your library should choose the methods that best suit 

your workflow.  

 

These instructions are subdivided into two parts.  The first covers the export of records from 

OCLC, and includes instructions for both Connexion via web browser in section I.A and the 

Connexion Windows client in section I.B.  The second part will cover importing records into the 

Voyager database using either the Cataloging client in section II.A or the Acquisitions client in 

section II.B.  

Part I. Exporting from OCLC  

I.A Exports Using Connexion via a web browser 

A library’s existing cataloging authorization will allow catalogers to log on to Connexion via a 

web browser at http://connexion.oclc.org/.  From there, users may search the WorldCat database 

and update/produce or export records. 

 

In the I-Share environment, you should choose the option to export bibliographic records or 

authority records to a file on the Connexion server, and then download the file to your 

workstation.   

 

To set your Preferences for export, on the General tab →Admin, choose Preferences from the 

drop-down menu and then select Export Options from the list. 

 

Choose MARC for the Flagged Bibliographic Record Export Format.   

 

Choose Export to a File for the Export Destination.   

 

In the “Fields to Delete on Export” section, Bibliographic record, input 035, and optionally 029.  

If you enter more than one field in this input box, be sure to separate the field tags with a comma.  

No punctuation other than a comma or a hyphen (to designate a range of field tags) should be 

included in this input box. 

 

The other Export options may vary depending on your local workflow. Consult the Connexion 

Help for information about the other options. 

 

Note: you do not need to fill in the TCP/IP sections because you are exporting to a file rather 

than to a TCP/IP Connection.   
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The “Export Options” in General tab →Admin → Preferences: 
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Once you have searched for and located a record, you may choose to view it in a “display” mode 

or an “editing” mode via the Edit drop-down menu.  To export the record, go to the Action drop-

down menu, and select Export Record in MARC.  This action puts the record into an export 

file on the Connexion server. 

 

 
 

Once you have records in an export file on the Connexion server, you must download them to 

your PC.  Go to the General tab → Admin and choose Download Export Files from the drop-

down menu.  Select the files to download by checking the box in the Select column, then click 

Download. 

 

 
 

In the dialog box that follows, save the file to your PC in a location of your choice.  Consult the 

Connexion Help for more information on downloading files. 

 

As of this writing, records are exported in non-Unicode format from the Connexion Web 

Browser.  This means the Voyager Cataloging Client must be set to import the records with a 

non-Unicode character set. MARC21 MARC8 (non-Unicode) is the best choice of the non-
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Unicode character sets because it allows the largest number of characters to be imported 

correctly.  For more information, see Part II. Importing MARC Records to Voyager below. 

Staff using Connexion Web should skip to Part II of this document.  The next section applies to 

users of the Connexion client only. 

 

I.B Exports Using the Connexion Windows Client 

The Connexion Windows Client offers a combination of the searching and editing flexibility 

found on Connexion’s web service with a Windows look and feel that includes menu-based 

commands and use of macros. 

 

By default, the Connexion client will prompt for a file name on exports; however, you may 

choose to define a set file name.  To create a standard export file, go to the Tools menu → 

Options → Export tab.   

 

Select the Create button. 

 

 
 

Then choose File and click the OK button. 
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In the “Export Filename” dialog box, change to the folder where you want your file, then enter 

the name of the file, and click Open to create the file, as seen in the example below. 

 

 
 

Confirm that you want to select this file as the default export file by clicking OK on the Export 

Destination File dialog box. 

 

 
 

When you are returned to the Options dialog box, click on the Record Characteristics button.   

  
 



Importing Bibliographic Records from OCLC to Local Voyager Databases 

Last revised by CARLI 2/17/2014  Page 6 of 11 

Originally created for ILCSO by Ted Schwitzner 

Choose UTF-8 Unicode in the Character Set boxes: 

 
Records will be exported in Unicode format, so the Voyager Cataloging Client Preferences must 

be set to import records in MARC21-UTF8. 

 

Next, click on the Field Export Options… button.   

 
 

In the Field Export Options box, enter 035, and optionally 029 into the “Fields to Delete 

Bibliographic Records:” inbox box.  If you enter more than one field in this input box, be sure to 

separate the field tags with a comma.  No punctuation other than a comma or a hyphen (to 

designate a range of field tags) should be included in this input box. 

 

 
 

Click OK. 
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For more information on why the 035 field should be Deleted from exported records, please see 

the document at  

http://www.carli.illinois.edu/mem-prod/I-Share/cat/oclcnmbrs.pdf  

 

Then click Apply and Close to close the Options window. 

 

The first time you export a record, this file will be created on your PC.  Any subsequent record 

exports during the same Connexion session will append to that same file.  If you perform record 

exports during later (new) Connexion sessions and the original export file still exists on your PC, 

you will be prompted to either Overwrite the file, Append the new records to the file, or Cancel: 

 
 

If you choose not to define a regular save file, Connexion will prompt you for a filename and 

location for the export file the first time you export.  This only occurs once for each time that you 

run the Connexion client.  If you have another file as the default export file, then no prompt 

appears when you export records. 

 

1. To export a record in the Connexion client, do the following: 

2. Connect to OCLC Services, using the connect button,  or using the File menu → 

Logon. 

3. Search WorldCat, using the search button,  or using the Cataloging menu → Search 

→ WorldCat (F2). 

4. Perform your search and locate the record you want for your catalog. 

5. With the record you want on the screen, you may click the export button,  or go to 

the Action menu → Export (F5).  For the first export of a session, if your export options 

are set to prompt for a file name, you must now enter the desired export file location and 

name. You will not be prompted again without closing and restarting the client. 

http://www.carli.illinois.edu/mem-prod/I-Share/cat/oclcnmbrs.pdf
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Part II. Importing MARC Records to Voyager 

You may import records into Voyager through either the Cataloging or Acquisitions client.  Both 

clients offer some workflow advantages, so library staff should familiarize themselves with each 

method. 

II.A Importing in the Cataloging Client 

Libraries may find that using the Cataloging client will be more efficient for importing records as 

this client can be configured to identify the default file locations for previously exported records 

(Options menu → Preferences → Folders/Files tab → Folders section → Import).  

Additionally, only in the Cataloging client can libraries edit a record prior to import.  Once a 

record has been imported in the Acquisitions client, it can only be edited or deleted via the 

Cataloging client.   

 

When bibliographic records have been exported from OCLC using the Unicode character set, the 

Voyager cataloging client must have its Preferences (Options  Preferences  Mapping 

tab Expected Character Set of Imported Records) set to MARC21 UTF-8.   

 

When bibliographic records have been exported from OCLC using the MARC8 character set 

(i.e., non-Unicode), the Voyager cataloging client must have its Preferences (Options  

Preferences  Mapping tab Expected Character Set of Imported Records) set to 

MARC21 MARC8 (non-Unicode).   

 

Except for very unusual circumstances, you’ll want to make sure that in the Cataloging client 

Preferences (Options  Preferences  General tab) that the Bibliographic Import/Replace 

Profile is set to OCLCConditional so that the system will detect duplicate records. 

 

If existing local records will be replaced by the imported records, library staff should take care to 

exercise safe bibliographic replacement techniques.
1
  This scenario frequently occurs with short 

records created for Acquisitions that need to be replaced with a full record when the item is 

received.  If this is the case, steps A and B below should be performed before step 1: 

A. If the bibliographic record is not already suppressed either with the “Suppress from 

OPAC” box checked or using the ‘Suppress from UC’ option where the bib contains 049 

$u nouc, suppress the record using one of these two methods.  Wait for the amount of 

time necessary according to the “Safe Bibliographic Record Replacement Routines” 

document. 

B. Once the necessary amount of time has passed, add the OCLC record number to the 

existing record.  Open the Cataloging client to search for the record and display it on the 

screen. Add an 035 field, subfield a, and enter the OCLC number with a prefix of 

(OCoLC)ocm or (OCoLC)ocn, depending on the number of digits in the OCLC number.  

                                                 
1
 Safe bibliographic replacement practices involve making changes to records in steps, in order to maintain the 

integrity of bibliographic and holdings records in the I-Share Universal Catalog.  For specific details on following 

these practices, see “Safe Bibliographic Record Replacement Routines.” 
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Save to DB. 

Ex.: 035 _ _ ‡a (OCoLC)ocm12345678 

035 _ _ ‡a (OCoLC)ocn123456789 

 

1. In the Cataloging client, go to the Record menu, choose Import  from New File.  

Select the file you created in the OCLC export. A list of the records will be displayed. 

2. To import any record, select it.  Note, you will need to click a record again to “unselect” 

it.  Click OK when ready to import. 

*Workflow note: Records may be imported one at a time or all at once. Single imports 

are preferred if any bib data should be edited.  Single imports also make it easier to deal 

with bib replacements.  Imported records will each appear in a separate window.  The 

title bar of each window will begin “Imported record” and will also include the record 

number from OCLC. 

3. Edit the bibliographic data as appropriate and according to your local cataloging practice. 

4. Click the Save to DB button (with the sailboat) to save the record in the database. 

a. If no duplicate records are detected and your preferences are set to do Authority 

Validation, you will see a list of headings used. If you will not be doing authority 

work immediately, click Continue.  After saving, the title bar of the record 

window will now display a BIB ID. 

Note: Clicking Close on this screen will cancel the save operation. 

*Workflow note: Unfinished records may be saved to a local file using the Save 

button if desired. 

b. If a duplicate record is detected in the database, or if you will be overlaying a 

short record, you will see the “Bibliographic Dedupe Detection” screen. 

 

This window will display duplicate records from the local database, along with a 

rank that indicates the strength of a match. Clicking Retrieve will display the 

selected duplicate record from the local database and cancel the save. Clicking 
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Close will cancel the save only.  

NB: The default button on this screen is Add as New Record.  If you hit the 

<Enter> key while on this screen, you will add the record, and possibly create a 

duplicate in your database.  Be sure to click the option you need. 

i. If the Rank is less than 100, view the duplicate records to see if they may 

represent different items (records that may have the same ISBN or ISSN 

or other numbers).  After evaluating the matching record, you may wish to 

click Add as a New Record if the new record represents a different title 

than the duplicates. 

ii. If the rank is 100 or greater; or 

you are replacing a short record; or  

you are replacing a bib record that has been upgraded in OCLC,  

click Replace/Merge using profile: OCLC Replace.   

Do not replace a bib record that does not match on the OCLC record 

number, which is listed in the 035 field of the duplicate bib.  This can 

possibly cause problems in the I-Share Universal Catalog (UC). 

 

II.B Importing in the Acquisitions Client 

The Acquisitions client is less flexible than the Cataloging client in importing records, as it does 

not provide the user with the ability to replace a duplicate record.  Instead, the user is prompted 

to link a purchase order line item to the existing bib record.  Still, if your library’s policies and 

workflow allow for selection of bib records during the order process, then the import function 

will serve you well. 

 

When bibliographic records have been exported from OCLC using the Unicode character set, the 

Voyager Acquisitions client must have its preferences (Tools  Workflows  Character Set 

Mapping for Local Import) set to MARC21 UTF-8.   

 

When bibliographic records have been exported from OCLC using the MARC8 character set 

(i.e., non-Unicode), the Voyager cataloging client must have its preferences (Tools  

Workflows  Character Set Mapping for Local Import) set to MARC21 MARC8.   
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1. Create a Voyager purchase order according to your library’s practices. 

2. Click Add Line (Bib Import) to retrieve records exported from OCLC.   

3. Choose the file containing the records exported for the order.   

 
 

4. Select the title(s) to add and click OK.   

5. Click Close when done selecting records, and the title(s) will be added to the bottom of 

the PO screen.  

If there is a matching record in the database, you will see the following prompt:  

 

You may answer yes to add the line item using the record from your database, but you 

may also want to investigate the record before approving the order. 

*Workflow note: It is possible, and perhaps desirable to add multiple line items to the 

purchase order at one time. Note however that the message above does not clearly note 

which title was duplicated. 


