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I. Introduction  
 
Before You Start…  

• These instructions cover a NEW installation of Oracle 12c on a Windows 10 (64-bit) workstation that has 
a 64-bit version of Microsoft Access 2013 or higher.  
 

• These instructions may be applied to earlier 64-bit versions of Windows (Windows 7 or Windows 8), 
though Oracle does not certify that the 12c clients are supported on those systems. 

 
• These instructions assume that no previous version of Oracle has been installed on the PC.  If your PC 

has an existing version of Oracle, please contact the CARLI Office before you begin this installation 
process. 
 

• A CARLI Oracle Account (username and password) is required before installation and to run MS Access 
reports or Strawn Utilities.  Your library’s Director or I-Share Liaison should request an Oracle 
username/password for each individual staff member by filing a Work Request Online (WRO). For more 
information, see http://www.carli.illinois.edu/products-services/i-share/reports/starting-access-reports . 

 
• If you run into problems at any point please stop and seek assistance from CARLI. The CARLI website 

contains a frequently asked questions list for Oracle installations. You may also contact CARLI staff at 
support@carli.illinois.edu. 

 
• The Oracle 12c 64-bit client will not work with Gary Strawn’s applications, which are 32-bit software. To 

use the Strawn tools, you may install the Oracle 10g 32-bit clients alongside Oracle 12c, making sure 
that the installations are in different directories. 
 

• CARLI’s servers require that the Oracle 12c client on the PC use encryption. If your campus uses 
Oracle clients to connect to other local Oracle databases, the encryption set up required to connect to 
CARLI servers may impede connections to local Oracle databases.  Before proceeding with this 
installation, consult your local IT staff and CARLI, if necessary. 

 
• Make sure that the Windows login used during this installation has Local Administrator rights before 

you begin. Consult your local IT Department if you are unsure or do not have Local Administrator rights.  
 

• Once the uninstall process has started, do not leave it unattended or start working on a different 
application until you have completed the process. Doing either may cause the application to freeze and 
require a reboot to resolve. Rebooting at the wrong time could greatly complicate the uninstall process.  

 
• Shutdown all other applications. Temporarily disable any PC firewall & virus software during installation.  

 
• If you are running Norton AntiVirus 2006 or later, linking in Section VI will not work by default. Read 

Microsoft's Knowledge Base Article 329820 (http://support.microsoft.com/kb/329820) for help. 
Otherwise, consult with your IT department.  
 

 
Why all the reboots?  
For a cleaner and faster uninstall (and install) process. Rebooting the PC…  

• …just before critical work helps minimize services competing for system resources.  
• …then shutting down all other programs minimizes program fragments and memory leaks.  
• …after making registry changes ensures that the link between PC files and previous registry data no 

longer exists.  

http://www.carli.illinois.edu/products-services/i-share/reports/starting-access-reports
http://support.microsoft.com/kb/329820
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How do I know which versions I’m using? 
To check whether your version Windows runs as 32-bit or 64-bits, choose from the following according to the 
operating system. 

 
Windows 10, option 1 
 
1. Select the Windows menu button 
2. Select the settings button 
3. Select the System icon 
4. Select the About option in the navigation pane. 
5. Check the System Type value. It will state either a 32-bit or 64-bit operating system. 
 
Windows 10, option 2 
 
1. Select the Windows menu button 
2. Find and Select the Windows System folder 
3. Select the Control panel icon 
4. Select the System icon 
5. Check the System Type value. It will state either a 32-bit or 64-bit operating system. 
 
Windows 8 
 
1. Select the Windows menu button 
2. Select the PC settings tile (a gear) 
3. Select the PC and devices option in the navigation pane 
4. Select the PC info option in the navigation pane. 
5. Check the System Type value. It will state either a 32-bit or 64-bit operating system. 
 
Windows 7 
 
1. Select the Windows menu button 
2. Select the Control panel icon 
3. Select the System icon 
4. Check the System Type value. It will state either a 32-bit or 64-bit operating system. 

 
To check whether your version of Access runs as 32-bit or 64-bits, do one of the following according to the 
application version. 

Access 2010 and later 

1. Open Microsoft Access 
2. Select Open Other Files 
3. Select Account 
4. Select the About Access button 
5. At the top of the About Microsoft Access window, you will find either 32-bit or 64-bit at the end of the 

line stating Microsoft Access 201X (X for the last digit in the version). 

Access 2007 

1. Open Microsoft Access 
2. Select the Microsoft Office button in the upper left corner 
3. Select Resources 
4. Select About 
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II. Downloading the Oracle 12c Client Package  
 
Before You Start  
 
The .zip download requires 900MB free space.  The installation requires an additional 500MB free space. In 

addition to the .zip file there is one other file to download. 
 
Instructions  
 

1.  Download the package and the additional file. 
 

a.  Locate and download the Oracle 12 installation files for 64-bit operating systems to your 
Desktop or Downloads folder:  

 
Version 12102 for Windows 64 bit (winx64_12102_client.zip)   
 

b.  Wait for the download to complete. This file (over 900MB) may take several minutes to 
download completely.  

 
2.  Extract the package  

 
a. Create a new folder on your PC that will be used when you will extract the .zip package in the 

next step. CARLI recommends naming the folder C:\Oracle12c.  
Warning: DO NOT create this new folder within an existing \oracle\ folder! 

 
b.  Locate and open the winx64_12102_client.zip file (e.g., by double-clicking). Windows’ built-in 

file extractor will be displayed. 
 
c. In the window, select Extract, then Extract All 

 
Figure 2-1. Extraction using Windows built-in file extractor. Select the Extract tab, then 

choose Extract All. 
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c. In the Extract Compressed (Zipped) Folders window, Change the default location that appears 
to C:\Oracle12c. Then choose Extract. 

 
Figure 2-2. Extraction using Windows built-in file extractor. Change whatever the default 

is (top image) to C:\Oracle12c (bottom image). 
 

 
 

 
 

3.  Once extraction completes, Windows will open a file explorer window for the new C:\Oracle12c folder. 
 

The Oracle 12c ODBC package is ready to install!  
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III. Installing Oracle 12c  
 
Before You Start  
 
Be sure that you have the Oracle 12c installation for your version of Windows, supplied by CARLI. See section 
II. Downloading the Oracle 12c Client Package for more information.  
 
Be sure that the Oracle installation files are in the folder you created, C:\Oracle12c. 
 
Be sure that you log on to the computer with administrative rights to install software and update the computer, 
and that you run the command prompt “As Administrator.” 
 
Installing Oracle 12c for Windows (64-bit) 
 

1.  Restart your computer.  
 
2.  Log on to the PC as an Administrator and ensure that there are no open programs.  
 
3.  Open a file explorer window and navigate to the folder containing the installation files, 

C:\Oracle12c\client.  
 

4.  Locate and open setup.exe. 
 
5.  Windows may prompt you to ask if setup.exe may make changes to the computer; answer Yes. A 

command line window will appear briefly checking the memory and graphics capability of your 
workstation. Then the Oracle Universal Installer will launch. 

 
6. On the Installation screen, choose Custom, then select Next. 

 
Figure 3-1. Universal Installer Installation screen. Select a custom installation. You may 

wait several minutes before reaching the next screen. Do not panic. 
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7. On the language screen, check that English is in the Selected Languages column on the right, and 
select Next. 

 
Figure 3-2. Universal Installer languages screen. Choose English. 
 

 
 
8. On the Oracle home user screen, keep the choice of Use Windows Built-in Account and select Next. 
 
9. On the installation location screen, type in the Oracle Base box, C:\Oracle. This should change the 

Software Location box as well. Select Next. 
 

Figure 3-3. Universal Installer installation locations screen. Highlight the text in Oracle 
base (top image) and change to C:\Oracle, which modifies both boxes (bottom image). 
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10.  When the Available Product Components screen appears, locate and select the following components: 

 
Oracle Net 
Oracle Connection Manager 
Oracle Net Listener 
Oracle ODBC Driver 

 
Figure 3-4. The Available Product Components screen with designated options checked.  
 

 
 

  
11.  Select Next. The installer will then perform pre-requisite checks over the next several minutes. 
 
12. At the summary screen, select Install to begin installing the files. The installation may last several 

minutes. 
 
Note: If you did not disable virus detection or desktop firewalls, you may receive a warning from 
Windows Firewall blocking the installer. Select the boxes for private networks and choose to allow 
access. 
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13.  As installation completes, the Oracle Net Configuration Assistant will open. Select the box for Perform 
typical configuration check box and click Next. 

 
Figure 3-5. Oracle Net Configuration Assistant screen. Choose to perform a typical 

configuration. 
 

 
 

14. The universal installer will return to the Finish screen. Select Exit to conclude installation.  
 

Oracle 12c ODBC is now successfully installed on Windows!  
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IV. Oracle/ODBC Configuration  
 
Before You Start  
 
These instructions cover a NEW installation of Oracle 12c on a workstation with no other Oracle instances 
installed. If your institution uses Oracle for other applications, and your workstation carries other versions of 
Oracle, you should consult with your information technology staff before configuring Oracle 12c. 
 
These instructions will configure your PC to run queries/reports against a copy of your library’s production 
databases, allowing you to run the CARLI Reports Access database or to use the Gary Strawn tools. Reports 
and queries can also be run against the Training databases; for configuration instructions to Training databases, 
see the document “Reporting Against the Voyager Training Databases” on the CARLI website. 
 
Part 1: Configuring the Oracle Service Name 
 

1.  Restart your computer. 
 
2. Log on to the PC as an Administrator and ensure that there are no open programs. 

 
3.  Locate and open Oracle Net Manager  

Select Windows menu > Oracle - OraClient12c_home1 > Net Manager. If prompted to allow 
launch.exe to make changes to your computer, answer Yes. Net Manager may take a few moments to 
open. 
 

Figure 4-1. Oracle Net Manager’s location on the Windows menu. 
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4.  When Net Manager opens, you should expand the configuration tree. Locate and select the plus for the 

Local folder. Then locate and select the plus for the Service Naming folder. 
 

Figure 4-2. Oracle Net Manager, locate the buttons to expand the configuration tree. 
 

 
 
 

5.  Highlight the Service Naming folder. Then select the Edit menu followed by Create. 
 

Figure 4-3. Oracle Net Manager, create a new service name with Edit > Create. 
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6.  The Net Service Name Wizard, page 1 of 5 appears. Enter VGER for the Net Service Name and then 
click Next. 

Figure 4-4. Net Service Name Wizard, enter the name with VGER. 
 

 
 

7.  On Net Service Name Wizard, page 2 of 5, choose choose TCP/IP (Internet Protocol) and click Next. 
 
8.  On Net Service Name Wizard, page 3 or 5, enter reports.carli.illinois.edu for the Host Name, and 

keep the default Port Number of 1521. Then click Next. 
 

Figure 4-5. Net Service Name Wizard, enter the report server address and port. 
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9.  On Net Service Name Wizard, page 4 of 5, in the Service Name box, enter your library’s three-letter I-
Share code in uppercase letters.  For example: CSC or GSU. See Appendix A for a list of I-Share library 
three-letter codes. Keep the default Connection Type of “Database Default”.  Then click Next. 

 
Figure 4-6. Net Service Name Wizard, enter your library’s three letter code in all caps. 

 

 
 

10. On Net Service Name Wizard, page 5 of 5, click Test. 
 
11. A database test will begin immediately using the default "scott/tiger" username and password. You will 

see a message “invalid username or password”. 
 

Figure 4-7. Connection test screen. Username “scott” doesn’t exist in your database. 
 

 
 
12.  Click the Change Login button.  
 

 
                                         Enter your I-Share code here  
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13.  Enter your Oracle username and password (not your Voyager operator ID), and click OK. Oracle 
usernames and passwords are case-sensitive. Enter them exactly as assigned by CARLI.  

 
Figure 4-8. Connection test login screen. Enter your oracle credentials. 

 

 
 

14. On the Connection Test screen, select Test. 
 

If you are using the correct username and password, then you should see the message “The 
connection test was successful.”   
 
If the test was unsuccessful, try the test again, making sure the Oracle username and password 
were entered correctly.  Also, please review the settings listed above.   
 
If the test continues to be unsuccessful, click Close and Cancel at the Test Service screen and 
contact the CARLI Office for assistance.  A failed test may indicate a problem with your network 
configuration, your Oracle installation, or your PC configuration. You may also wish to verify that 
your Oracle account name and password are correct on a workstation where Oracle is already 
working. 

 
15.  If the test was successful, close the Connection Test window by selecting Close, then select Finish to 

complete the Net Service Name Wizard. 
 

Figure 4-9. Net Manager with a successfully configured service name. 
 

 
 
 
16. From the Net Manager screen, choose File > Save Network Configuration to save your work.  
 
17. Exit Net Manager by choosing File > Exit 
 

Oracle 12c is now successfully configured on Windows!  



CARLI   REV 4/9/2018 

Confidential and proprietary information of Ex Libris Group, Inc. Copyright © 2007. Ex Libris Group, Inc. All rights reserved. CARLI has 
added important information local to CARLI’s Voyager environment and necessary for connecting to CARLI servers.                Page 15 of 27 

Part 2: Configuring the 64-bit Microsoft ODBC Administrator 
 
These instructions cover configuration of the 64-bit Oracle ODBC driver only in 64-bit Windows environments. 
Instructions for Windows 32-bit systems are available on the CARLI website. 

 
16.  Locate and open the 64-bit ODBC Data Source Administrator. 

Windows menu > Windows Administrative Tools > ODBC Data Sources (64-bit)  
 

Figure 4-10. Windows menu open to ODBC Data Sources. Select the 64-bit version. 
 

 
    

 
17. Open the System DSN tab (the 2nd tab) 
 

Figure 4-11. The 64-bit ODBC Administrator application, set to the System tab. 
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18. Click Add to create a new Name.  Choose the “Oracle in OraClient12Home1” driver type and click 
Finish.  

 
Figure 4-12. New Data Source driver list, find Oracle in OraClient12Home1. 

 

 
 

19. In the Oracle ODBC Driver Configuration box that appears, enter these values: 
[Data Source Name] eisreport64  
[Description] Voyager Production Reporting 64-bit 
[TNS Service Name] VGER 
[User ID] <your Oracle username> 

Do not change any settings on the bottom half of the configuration screen. Click OK.  
 

Figure 4-13. Oracle ODBC Driver Configuration screen.  
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20. Next, test the ODBC connection by creating a File DSN entry. 
a. Open the File DSN tab (the 3rd tab) and select Add. 
 
b. Select type Oracle in OraClient12Home1 and select Next. 
 
c. Name this New Data Source vger and select Next. 
 

Figure 4-14. Creating a File Data Source, enter “vger” (or any name) for the test. 
 

 
 
d. Select Finish. 
 
e. In the Microsoft ODBC for Oracle Connect box that appears enter these values and select OK: 

[User Name] <your Oracle username> 
[Password] <your Oracle password> 
[Server] VGER 
 

Figure 4-15. Using the file data source name to test the connection. 
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f. If the box disappears and you find yourself back at the third tab, the test was successful. If you 

receive an error message, please check the values you entered and try again. Also, check the 
values created in the System DSN created above and try again. If the error message persists, 
contact the CARLI Office for assistance.  

 
Figure 4-16. If the file data source test works, you’ll return to the ODBC Administrator 

screen without any errors. 
 

 
 
g. If all was successful, delete the File DSN you just created by highlighting the name vger.dsn and 

clicking Remove. Answer Yes when asked if you are sure you want to remove the data source. 
 

21. Exit the ODBC Data Source Administrator by clicking OK. 
 

Your workstation is now successfully configured to connect to Voyager 
over Oracle 12c ODBC!  
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V. Link the CARLI_Reports.mdb File  
 
Before You Start  
These instructions cover installation of a freshly installed or downloaded copy of the CARLI_Reports_20XX.mdb 
database file, and configuring that file to run queries and reports against your library’s production Voyager 
database.  
 
CARLI strongly recommends that you use the latest version of the CARLI Reports file in place of the generic 
Reports.mdb file. As of this writing the latest file is CARLI_reports_2016a.mdb file. 
CARLI_reports_20XX.mdb files include the shared SQL and reports prepared by CARLI staff and I-Share 
library staff, along with Ex Libris’ pre-packaged reports that I-Share libraries may find useful. 
 
If you already have a previous CARLI_Reports.mdb file from another workstation, you may be able to continue 
using that .mdb without any additional configuration.  If the .mdb file does not work, simply try relinking it 
according to the instructions below. The CARLI website also includes instructions for copying queries from your 
old file into the new database file. 
 
These instructions apply only to workstations running 64-bit versions of Microsoft Access 2013 and later. If your 
institution only offers 32-bit Office, check the CARLI website for the correct instructions. At this time, Office 365 
installations of Access are not supported. 
 
Instructions for MS Access 2013 or later 

1.  Open your new CARLI_Reports database file. If you are prompted with a security warning, select 
Enable Content. 

 
Figure 5-1. Access provides a security warning about the macros and scripts that make 

the reports database more effective. Choose to enable the content. 
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2.  Enable Access to run the table linking macros by selecting File > Options, then select Trust Center in 

the navigation pane, and finally select the Trust Center Settings… button. 
 

Figure 5-2. Access Options window, choose Trust Center, then Trust Center Settings. 
 

 
 

3.  Select Macro Settings in the navigation pane. Then, select the button next to Enable all macros. 
Select OK to close the Trust Center, then select OK again to close Access Options. 
 

Figure 5-3. Access Trust Center, choose Macro Settings, then Enable all Macros. 
 

 
 

4. Exit and restart MS Access. 
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5. Open the CARLI_Reports_20XX.mdb and begin linking tables by selecting External Data > ODBC 
Database. 

 
Figure 5-4. Begin linking the database from the External Data ribbon. 

 

 
 

 
6.  On the Get External Data‐ODBC Database screen, select Link to the data source by creating a 

linked table, then select OK. 
 

Figure 5-5. The Get External Data wizard screen, choose to link to the data source. 
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7. On the Select Data Source screen, select the Machine Data Source tab, then locate and choose 
eisreport64, and click OK. 

 
Figure 5-6. The Select Data Source screen should show you the data source name that 

you created in section IV part 2. If not, you may be on a 64-bit version of Access. 
 

 
 

 
8. When the Microsoft ODBC for Oracle Connect screen appears, enter these values and select OK.  

 
[Service Name] VGER 
[User Name] <your Oracle username> 
[Password] <your Oracle password> 
 

Figure 5-7. The Microsoft ODBC for Oracle Connect screen prompts for your Oracle 
credentials. 

 

 
 

NOTE: It may take a few minutes before the next screen appears.  
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9. When the Link Tables screen appears, choose Deselect All. Wait for the button to refresh, and select 
OK.  

Figure 5-8. The Link Tables window; when you choose Deselect All, the button may stay 
dimmed for a few moments.  

 

 
 

10. Go to the Access navigation pane, and change the listing to Forms; Select the drop-down arrow, then 
locate Forms on the list. 

 
Figure 5-9. Access Navigation Pane provides a list of different objects in the database. 

Select the down arrow to choose different categories. Choose Forms.  
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11. Locate and open the Build database links to Voyager form. 
 

Figure 5-10. Open the Build database links to Voyager form. 
 

 
 

12. In the Build database links to Voyager form, enter the following values. Remember that values are 
case-sensitive. 

 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
***Where XXX represents your I-Share Voyager three-letter code in uppercase letters.  See Appendix A. 

ODBC Name eisreport64 

Connect String VGER 

DB User ID  
(remove dbread) 

<your Oracle Username> 

Password  
(remove existing *s) 

<your Oracle Password> 

Tablespace*** XXXDB 

Relink checkbox Checked 
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13. Click Connect. The status window of the form will list each table as it is successfully linked. The linking 
process may take several minutes. 
 
If you receive "error!" statements followed by "Process stopped too many errors!,” click Close and 
repeat steps 11-12 again, carefully checking the information being entered.  If you continue to receive 
error messages, contact the CARLI Office for assistance. 

 
Figure 5-11. The Build database links to Voyager form, with the status box showing that 

all tables have been linked. 
 

 
 

14. When the linking completes the status window will return to the first table; you may scroll to the end to 
see if the message “Linking Completed” appears. Select Close to close the build links form. 

 
The CARLI Reports database is now successfully linked! 

You may now run queries and reports against the database. 
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LIBRARY CODE  LIBRARY CODE 
Abraham Lincoln Pres Lib & Museum ALP  MacMurray College MMC 
Adler University ADL  McHenry County College MHC 
Augustana College AUG  McKendree University MCK 
Aurora University ARU  Meadville Lombard Seminary MLS 
Benedictine University BEN  Millikin University MIL 
Black Hawk College BHC  Monmouth College MON 
Bradley University BRA  Moody Bible Institute MBI 
Carl Sandburg College CSC  Morton College MRT 
Catholic Theological Union CTU  National-Louis University NLU 
Chicago State University CSU  The Newberry Library NBY 
College of DuPage COD  North Central College NCC 
Columbia College COL  North Park University NPU 
Concordia University Chicago CON  Northeastern Illinois University NEI 
Danville Area Community College DAC  Northern Illinois University NIU 
DePaul University DPU  Northern Seminary NBT 
Dominican University DOM  Oakton Community College OAK 
Eastern Illinois University EIU  Olivet Nazarene University ONU 
Elmhurst College ELM  Parkland College PRK 
Eureka College ERK  Principia College PRC 
Governors State University GSU  Quincy University QCY 
Greenville College GRN  Richland Community College RCC 
Harper College WRH  Robert Morris University RMC 
Heartland Community College HRT  Roosevelt University ROU 
Illinois Central College ICC  Rush University RSH 
Illinois College ILC  Saint Francis Medical Ctr College of Nursing SFM 
Illinois Eastern Community Colleges IEC  Saint Xavier University SXU 
Illinois Institute of Technology IIT  Sauk Valley Community College SVC 
Illinois Math & Science Academy IMS  School of the Art Institute Chicago SAI 
Illinois State Library ISL  South Suburban College SSC 
Illinois State University ISU  Southeastern Illinois College SEI 
Illinois Valley Community College IVC  Southern Illinois University Carbondale SIC 
Illinois Wesleyan University IWU  Southern Illinois University Edwardsville SIE 
JKM Library JKM  Southern Illinois University School of Medicine SIM 
John Wood Community College JWC  Southwestern Illinois College SWI 
Joliet Junior College JOL  Spertus Institute of Jewish Studies SCJ 
Judson University JUD  Trinity Christian College TRN 
Kankakee Community College KCC  Trinity International University TIU 
Kishwaukee College KIS  Triton College TRT 
Knox College KNX  University of Illinois at Chicago UIC 
Lake Forest College LFC  University of Illinois at Springfield UIS 
Lewis & Clark Community College LAC  University of Illinois at Urbana-Champaign UIU 
Lewis University LEW  University of Saint Francis USF 
Lincoln Christian College & Seminary LCC  University of St. Mary of the Lake SML 
Lincoln College LNC  Western Illinois University WIU 
Lincoln Land Community College LLC  Wheaton College WHE 
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