
CARLI Draft Document: Deleting Records from Alma  12/7/2020 p.1 

Deleting Alma Records 
Deleting Bibs/Holdings/Items 
When deleting any physical inventory, one must start with the end-most parts first. Delete items, then 
holdings, then bibs. The approach to deleting item records is to Withdraw the item. This is true even if 
you are deleting a record you created accidentally. Options for deleting items include manual deletion 
from the items list and creating a set then processing the set with the Withdraw Items job. 

Roles 
Deleting item records requires the Physical Inventory Operator and Physical Inventory Operator 
Extended roles. 

Deleting electronic inventory requires the Electronic Inventory Operator and Electronic Inventory 
Operator Extended Roles. 

Deleting bibs and holdings within the metadata editor requires the Cataloger Extended role in 
combination with Cataloger, or the Catalog Manager role. 

Deleting inventory using jobs requires the Catalog Manager or Repository Manager role. 

Bib records may be deleted when the following conditions are true: 

• No inventory exists 
• Any PO lines that are present must be either Closed or Cancelled 

Delete/Withdraw single item for a title 
Searching by title 

1. Perform a Physical Titles or Physical Items search scoped to your institution to locate the record, 
e.g., using Title or Keywords 

2. Expand details view and click Items; or use actions menu and select Items. 
• If Alma brings you to the item record editor, expand the information bar, then click View 

all items.  
3. On the List of Items screen, click the actions menu for the item record, then select Withdraw. 
4. At the Confirmation Message, click Confirm. 
5. When the item is the only/last item on a bib, you will be prompted about what to do with the 

holding and bib; under this scenario, select Delete Bibliographic Record, then click Go. 
6. After the screen refreshes, you may still be viewing the list of items screen. Click the go back 

arrow; Alma should refresh the results with the title no longer listed. 

Searching by item (e.g., by Barcode) 
1. Perform a Physical Items search on Barcode scoped to your institution. 
2. Click the actions menu, then select Withdraw.  
3. At the Confirmation Message, click Confirm. 
4. When the item is the only/last item on a bib, you will be prompted about what to do with the 

holding and bib; under this scenario, select Delete Bibliographic Record, then click Go. 
5. Alma should refresh the results with the item no longer listed. 
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If you’re unsure whether there are additional items associated with the bib or holding, you may want to 
select the searching by title method. 

Delete/Withdraw multiple items, same title 
1. Perform a Physical Titles search scoped to your institution to locate the record. 
2. Expand details view and click Holdings; or use actions menu and select Holdings. 
3. On the List of Holdings screen, click the actions menu and then select View Items. 
4. On the List of Items screen, tick the boxes for each item that you intend to delete. 
5. Select the Manage Selected menu, then click Withdraw Items. 
6. At the Confirmation Message, click Confirm. 
7. When the item is the only/last item on a bib, you will be prompted about what to do with the 

holding and bib; under this scenario, select Delete Holding Record, then click Go. 
8. After the screen refreshes, you may still be viewing the list of items screen. Click the go back 

arrow; Alma should refresh the results with the title no longer listed. 

Delete/Withdraw multiple items, multiple titles 
When deleting multiple items across multiple titles, it may be the most effective to run the deletions in a 
batch. 

1. Enter the barcodes of items to delete into an Excel file. Make sure the column heading reads 
“Barcode”. 

2. Save the file somewhere on your workstation that is easy to find. 
1. Go to Admin > Manage Jobs and Sets > Manage Sets. 
2. Click Create Set, then select Itemized set. 
3. Provide a set name and description. 
4. Select the Set Content Type of Physical items, then change Private to No. 
5. Under Add Contents, select From File. Then click the folder to browse to the location of your 

Excel file.  
6. Select the report that you created earlier, then click Open. Click Save to create the set. Allow 

some time for the set to be created. You should receive an email notification when the set is 
ready.  

7. Optionally, review the itemized set and remove any set members that you don’t want to delete. 
8. Go to Admin > Manage Jobs and Sets > Run a Job. 
9. Locate and select the Withdraw Items job, then click Next. 
10. Locate and select your barcode set, then click Next. 
11. On the task parameters screen, select options for how associated records should be handled, 

whether holdings and bibliographic records should be deleted or suppressed. Tick the boxes to 
block deletion of items with requests and work orders. 

12. Click Next.  
13. Review the job settings, click Submit, then click Confirm when prompted. You will receive an 

email notification when the job completes. 

Deleting Bibs/Holdings without Items 
Manually delete holding, then bib, from Metadata Editor 

1. Perform a Physical Titles search scoped to your institution to locate the record. 
2. Click Edit Record to open the bib in the MDE. 
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3. Get inventory with Ctrl+I, or go to Tools > MARC Bibliographic > View Inventory (old MDE), or go 
to View Related Data > View Inventory (new MDE) 

4. Click Edit to open the holdings record in the split-screen view. 
5. Go to the File menu (old MDE) or the Record Actions menu (new MDE) 
6. Select Delete Record, click Yes when asked for confirmation. 
7. If the holding is the last holding on the record, you will be asked about deleting the bib record. 

Click Yes to confirm deletion if no other holdings are present. 
8. The MDE should refresh with an empty workspace.  
9. You may sometimes get a warning that a NZ bib cannot be deleted as other members are still 

using the bib, or that they have a local version of the record that cannot be deleted. When this 
happens, go to the process for unlinking and deleting NZ bibs below. 

Create set of records and use Delete Holding Records with No Items job 
1. Perform an advanced Physical Titles search, scoped to your institution, with index of Has Items 

equals No. Include other indexes and criteria as needed. 
2. Provide a set name and description. Change Private to No. Then click Save.  
3. Go to Admin > Manage Jobs and Sets > Manage Sets, click the Public Sets or My Sets tab to see 

when the set is ready.  
4. Locate the set, then click the actions menu, and select Itemize to create an explicit set of records 

to delete. Optionally update the set name, description, and privacy setting. Click Submit when 
done. Itemizing a set may take a while. You will receive an email notification when the set has 
been created. 

5. Optionally, review the itemized set by locating it on the My Sets tab, click the actions menu and 
select Members. Tick the box for any set members that you don’t want to delete, then click 
Remove Selected. Click Done when ready. 

6. Go to Admin > Manage Jobs and Sets > Run a Job. 
7. Locate and select the Delete Holding Records with No Items job, then click Next. 
8. Locate and select the record set you created above, then click Next. 
9. On the task parameters screen, you may choose to limit the action to a specific library and 

location, or to filter by an indication rule. Select whether to delete or suppress bibliographic 
records. Then click Next. 

10. Review the job details, then click Submit. You will receive a notification when the job completes. 

Deleting Bibs with no inventory 
Manually delete bib from Metadata Editor. 

1. Perform an All Titles search scoped to your institution to locate the record. 
2. Click Edit Record to open the bib in the MDE. 
3. Go to the File menu (old MDE) or the Record Actions menu (new MDE) 
4. Select Delete Record, click Yes when asked for confirmation. 
5. If the bib is linked to the NZ, and other libraries still have holdings, you will receive a message 

that the bib may not be deleted.  
a. Go to the File menu (old MDE) or the Record Actions menu (new MDE), then select Copy 

to Catalog. This breaks the link and copies the record contents into the IZ shell for your 
record. 

b. Wait for the MDE to refresh. 
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c. Go to the File menu (old MDE) or the Record Actions menu (new MDE), then select 
Delete Record. This deletes your bib, which now exists as IZ-only, and does nothing to 
the NZ or CZ bib. 

d. The MDE should refresh with an empty workspace. 

Create a set of records and use Delete Bibliographic Records job. 
1. Perform an advanced All Titles search, scoped to your institution, with index of Has Items equals 

No. Include other indexes and criteria as needed. 
2. Click Save Query; provide a set name and description that will remind you what you’ve included 

and what you plan to do with the set. Change the private value to No. Click Save. You should 
receive an email notification when the set has been created. 

3. Go to Admin > Manage Jobs and Sets > Manage Sets, click the Public Sets or My Sets tab to see 
when the set is ready.  

4. Locate the set, then click the actions menu, and select Itemize to create an explicit set of records 
to delete. Itemizing a set may take a while. 

5. Refresh the sets page or wait for the notification to arrive. Locate the itemized set, click the 
actions menu, and select Members.  

6. You may export the list to Excel for review, or page through results. If you need to remove any 
records that shouldn’t be deleted, tick the box next to the record number and click Remove 
Selected. Click Done when ready to move on. 

7. Go to Admin > Manage Jobs and Sets > Run a Job. 
8. Locate and select the Delete Bibliographic Records job. Click Next. 
9. Select the itemized set that you created above, then click Next. 
10. Tick the option for Delete all associated inventory resources. Click Next. 
11. Review the job details, then click Submit. Click Confirm when prompted. 
12. You will receive a notification when the job completes. 
13. Go to Admin > Manage Jobs and Sets > Monitor Jobs, click the History tab. 
14. Locate the report with “Delete Bibliographic records – [your set name]”, click the actions menu, 

then select Report. From the report screen, you may choose to download an Excel version of the 
Detailed Counters report. 

Deleting Bibs and Standalone Portfolios 
Manually deactivate portfolio, delete portfolio from portfolio editor. Manually delete bib from MDE. 

1. Perform an Electronic Titles or Electronic Portfolios search scoped to your institution to locate 
the record. 

2. Locate the title in the results, click Portfolio List. 
3. On the portfolio list for the title, click the actions menu, then select Deactivate. Wait for Alma to 

refresh the screen before continuing. 
4. On the portfolio list for the title, click the actions menu, then select Delete. 
5. You’ll be asked to confirm deletion and decide what to do with the bib. Select Delete 

bibliographic record(s) then click Confirm; or if you need to retain the bib (e.g., for a PO line), 
select Suppress bibliographic record(s) then click Confirm. 
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Create set of records from a search and use Delete Portfolios job 
1. Perform a search for electronic titles or electronic portfolios, scoped to your institution, then 

click Save Query on the results. 
2. Provide a set name and description. Change Private to No. Then click Save.  
3. Refresh the My Sets or Public Sets tab, then locate the set you just created. Click the actions 

menu, then select Itemize. 
4. Optionally update the set name, description, and privacy setting. Click Submit when done. You 

will receive an email notification when the set has been created. 
5. Optionally, review the itemized set by locating it on the My Sets tab, click the actions menu and 

select Members. Tick the box for any set members that you don’t want to delete, then click 
Remove Selected. Click Done when ready 

6. Go to Admin > Manage Jobs and Sets > Run a Job. 
7. Locate and select the Delete Portfolios job, then click Next. 
8. Locate and select your portfolio set, then click Next. 
9. On the task parameters screen, select options for what should happen if the portfolio is linked 

to active PO lines or activation tasks; select whether to delete or suppress the bib. Click Next. 
10. Review the job settings, click Submit, then click Confirm when prompted. You will receive an 

email notification when the job completes. 

Create set of records from analytics and use Delete Portfolios job 
1. Open Analytics, then create a new analysis to locate portfolios that you want in your results. 

Make sure that Portfolio ID is one of the fields in the results display.  
2. Save the analysis into your institution’s shared folder, e.g., /Shared Folders/[institution 

name]/Reports. 
3. In Alma, go to Admin > Manage Jobs and Sets > Manage Sets. 
4. Click Create Set, then select Itemized set. 
5. Provide a set name and description. 
6. Select the Set Content Type of Electronic Portfolios, then change Private to No. 
7. Under Add Contents, select From Analytics. Then choose the shared reports folder.  
8. Select the report name that you created earlier, then click Save. Allow some time for the set to 

be created. You should receive an email notification when the set is ready.  
9. Optionally, review the itemized set by locating it on the My Sets tab, click the actions menu and 

select Members. Tick the box for any set members that you don’t want to delete, then click 
Remove Selected. Click Done when ready. 

10. Go to Admin > Manage Jobs and Sets > Run a Job. 
11. Locate and select the Delete Portfolios job, then click Next. 
12. Locate and select your portfolio set, then click Next. 
13. On the task parameters screen, select options for what should happen if the portfolio is linked 

to active PO lines or activation tasks; select whether to delete or suppress the bib. Click Next. 
14. Review the job settings, click Submit, then click Confirm when prompted. You will receive an 

email notification when the job completes. 

Deleting Bibs and Portfolios in Collections 
1. Perform a search for electronic collections scoped to your institution, for example, using 

Electronic Collection Name. 
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2. Locate the collection and click the actions menu, then select Delete. 
3. You will see a confirmation message that identifies the number of portfolios that will be deleted. 

Select whether to suppress or delete the associated bib records, then click Confirm. 
4. Deleting collections results in a delete job being submitted, and the collection should be 

updated as being “(in deletion process)”. You should receive an email notification when the job 
completes. DO NOT add any new collections that may overlap with this collection while the 
delete job is running. 

Can I delete bibs that are attached to PO Lines? 
• Yes, IF the PO line is Cancelled or Closed, you may delete the inventory and bib using any 

method above. 
• No, IF the PO line has any other status, such as Ready, Sent, Waiting for Invoice, Waiting for 

Renewal; you will have close the PO line first, or delete the acquisitions data. 

Does OCLC get updated when I delete bibs? 
*Yes (it should, we’re working on an issue with how that’s working). 

Every institution has been configured to use the Publishing to OCLC job, which is tied to your 
institution’s OCLC Data Sync Collection that CARLI established. The Publishing to OCLC job outputs 
bibliographic records that contain OCLC record numbers in the 035 for records that are updated in Alma. 
This job runs every morning for physical inventory, and once per week for electronic inventory. 

The publishing job sends OCLC a bib with a deletion indicator (Leader/05 = “d”) and a 994 $b containing 
your holding symbol when any of the following happen: 

• The bib record is deleted in Alma 
• All holdings of a bib have been deleted 
• The bib record was marked as Don’t Publish after having been published at least once. This 

means marking the Export to WorldCat management tag as Don’t Publish. 

Does suppressing a bib or holding send a delete to OCLC? 
No. The only actions that send a delete to OCLC are: 

• Deleting a bib and its inventory. 
• Deleting all of the inventory for a bib. 
• Changing the management tag of a bib: Tools > Set Management Tags > Publish to OCLC 

When would I choose to suppress an empty bib or holdings instead of deleting the record? 
• If you need to retain metadata for historical purposes (e.g., insurance records, special 

collections history) 
• If you may re-use the record again (e.g., you’re ordering a replacement copy) 
• If the records are associated with PO lines. 

How do I delete an empty bib that is still linked to the network zone or to the community zone? 
1. Open the bib for editing in the MDE. 
2. Go to the File menu, select Copy to Catalog. This breaks the link and copies the record contents 

into the IZ shell for your record. 
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3. Wait for the MDE to refresh. 
4. Go to the File menu, select Delete Record. This deletes your bib, which now exists as IZ-only, and 

does nothing to the NZ or CZ bib. 
5. The MDE should refresh with an empty workspace. 

Alternately, you may also follow the steps above to delete bibs with no inventory. 

Does deleting a bib linked to the NZ affect the NZ bib? 
• If other libraries still have inventory, physical or electronic, on the bib, then NO. 
• If you are the last institution with a link to the bib, then YES. Go ahead and delete the empty bib. 

What happens to data in Analytics for deleted records? 
• Records are retained; lifecycle for records is changed to “Deleted.” Deletion date is saved as 

Modification Date: 
• The retained record includes only the data that had been in Analytics the day before. 

How do I know the difference between an item that was weeded/withdrawn and something I 
deleted because it was wrong? I.e., How do I count the number of items I withdrew in a 
day/month/year? 
Analytics will help easily tabulate the numbers of bibs, holdings, and items in your collection at a given 
time. But if you have to keep statistics on your own activities or track the volume count for the library, 
you may want to use the notes fields on the item record.  

Your process should involve adding one or more of the following types of data to an item record. Then 
wait a day so that Alma’s analytics export will update item data in analytics. You may then withdraw the 
item using the processes above. 

Option 1. Use Statistical Notes.  
Statistical notes may be entered as free-text fields, or you may configure them to have specific statistical 
codes for tracking data. In either case, you’ll want the data to be consistent for capturing stats.  

For example, you might establish that Statistical Note 3 will include details about weeding, then create a 
value of “Withdrawn 2020.” This is done in configuration. Then, in item records that are being 
withdrawn, assign that note to Statistical Note 3 of the items being withdrawn. Save the record. [wait a 
day for analytics to update?] You may then withdraw the item as above. 

To make statistics notes use controlled lists of values instead of free text, go to Configuration > 
Resources > Other Settings. Change the value of setting statistics_note_controlled to true. This will 
create three new configuration options, Statistics Note 1, Statistics Note 2, and Statistics Note 3. Click 
these options to create the controlled value lists. Consider using each note to cover different facets, 
rather than duplicating the same value lists for each note. 

Option 2. Use Internal Notes. 
You could use an internal note for the same purpose, but internal notes are free text only, and might be 
harder to standardize over time.  
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Option 3. Use a weeding date and weeding number.  
You may configure Alma to assign sequential values to weeded items. This might be especially useful if 
auditors track your collections. By configuring a weeding sequence, new fields will appear in the item 
record. 

When withdrawing items, scroll down the item record to the Inventory section. Enter the weeded date 
to specify the date of the decision. You may also click Generate to create a sequence number. Save the 
record.  

Option 4. Use a combination of the above. 
If you prefer, you may record the data in multiple ways to ensure redundancy or provide more facets to 
the retained data. 

Is there a way to do that for holdings and bibs too? 
• Possibly, but doing so might involve more activity than needed for the task of deleting records. 
• Most of the jobs discussed will include record totals. 

If I accidentally deleted a record, is there a way to get it back? 
Yes! If you have the Repository Manager role, you will be able to retrieve records deleted individually or 
by jobs. However, this process does not restore PO lines. 

Restoring individual records. 
1. Go to Resources > Advanced Tools > Manage Deleted Repository 
2. Select the type of record you want to restore in the Find box. 
3. Select whether you are searching for records according to who/how they were deleted. 

• Deleted by – options are a specific user or a specific job id 
• Deleted range – covers a range of dates only 
• MMS ID/PID – specific record ID or process ID. 

4. Select the other criteria (e.g., user or job, date range), then click Search. 
5. You will get a record list similar to other search results lists. You can export the list to Excel if you 

want to review additional details.  
6. Locate the record you want, then click Restore. 
7. The Confirm Restore window will show you what records will be restored. Click Confirm if ready. 

Restoring the results of specific jobs 
1. Go to Resources > Advanced Tools > Restore Jobs 
2. Enter the job id that made the changes (Get this information from Admin > Monitor Jobs > 

History tab) 
3. Click Restore, then Confirm. 
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Deleting Acquisitions Data 
As with bibs, delete from the end-most points first: Invoices, then purchase orders and PO lines, then 
funds/vendors. 

Roles 
To delete invoices, you will need the Purchasing Operator and Purchasing Operator Extended roles, and 
these should be scoped to the institution and to the library where acquisitions activities are performed. 

To delete PO lines, you will need the Invoice Operator and Invoice Operator Extended roles, and these 
should be scoped to the institution and to the library where acquisitions activities are performed. 

Deleting vendors requires the Vendor Manager role. 

Deleting funds requires the Fund Manager role. 

Invoices 
1. Search for the invoice to delete, e.g., Invoices by PO Line. 
2. Locate the invoice to delete, click the actions menu, then select Set Back to Review. Click 

Confirm to move the invoice to review. 
3. Go to Acquisitions > Receiving and Invoicing > Review (Invoice). Click to the Unassigned tab. 
4. Locate the invoice to delete, click the actions menu, then select Delete. Click Confirm when 

prompted. 

Deleting an invoice will also delete the expenditure transaction(s) to the fund(s) on the invoice line(s). 
However, the deletion does not also re-encumber money or re-open the associated PO line(s). 

There is not a batch job to delete invoices from Alma. 

PO Lines 
Deleting PO Lines Manually 

1. Search for the PO line you want to delete, e.g., Order Lines by PO Line or Title. 
2. Locate the PO line you want to delete, click the actions menu, then select Reopen. 
3. Go to Acquisitions > Purchase Order Lines > Review (PO Lines). Click to the Unassigned tab. 
4. Locate the PO line you want to delete, click the actions menu, then select Delete. Click Confirm 

when prompted. 

Deleting Purchase Orders 
Purchase orders as a whole  

1. Go to Acquisitions > Purchase Order (PO) > Delete PO. 
2. Enter the PO number to delete, or click the Select from a List button to search for purchase 

orders. 
3. Click Delete PO, then click Confirm. 

What happens to inventory (holdings + items/collections + portfolios) if I delete PO lines? 
• Deleting a PO Line will delete all attached inventory from Alma. You must locate the bib using an 

All Titles search after inventory are removed.  
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Vendors 
Alma does not block the deletion of vendors, except when there are active PO lines (i.e., status is not 
Closed) or when the vendor has one or more interfaces assigned. This means that it is possible to delete 
a vendor that is still in use for closed PO lines and invoices. While data on deleted vendors may still be 
found in Analytics, staff may find it more difficult to work with PO lines and invoices in Alma.  

CARLI recommends that if a vendor is still associated with other acquisitions activity, make the vendor 
inactive instead of deleting the record. 

1. Go to Acquisitions > Acquisitions Infrastructure > Vendors. 
2. Locate the vendor you want to delete, click the actions menu, then select Edit. 
3. Review the PO Lines and Invoices tabs to verify whether there are any active records on the 

vendor. The lists on these screens may be exported to Excel. 
4. Go to the Summary tab, select Status to be Inactive. Click Save. 
5. On the search vendors screen, change the filter on Vendor Status to Inactive. 
6. Locate the vendor you want to delete, click the actions menu, then select Delete. Click Confirm 

when prompted. Alma will alert you if there are any objects preventing the record from being 
deleted. 

Funds 
Funds may be deleted if they are no longer actively in use in a ledger. For example, deleting a fund that 
was used in previous years’ ledgers but is no longer used. Funds that have associated transactions 
(encumbrance, expenditure, allocation) cannot be deleted by library staff. 

1. Go to Acquisitions > Acquisitions Infrastructure > Funds and Ledgers. 
2. Alma will present a list of active funds and ledgers for the current fiscal year. Locate the fund 

that you want to modify, then click Edit. 
3. Click the Transactions tab to review whether any encumbrances or expenditures are attached. 
4. Click Deactivate at the top of the screen. 
5. Modify the facets for the funds list: click the X next to Active to show all funds, then select the 

Inactive facet. 
6. Locate the fund in the list. IF the fund has no encumbrance or expenditure transactions, you 

make click the actions menu, then select Delete. 
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Deleting Users 
Users may be deleted from Alma if there are no active transactions, such as: 

• Balance due or outstanding loans 
• Listed as Interested Users on PO lines 
• Assigned as a staff member to PO lines, invoices, bib records, import profiles 

Roles 
Deleting users requires either the User Administrator or User Manager role. 

Deleting Users Manually 
1. Go to Admin > User Management > Manage Users. 
2. Search for the user by name or identifier. 
3. Locate the user in the results, click the actions menu, then select Delete. 
4. Click Confirm when prompted. 
5. If the user cannot be deleted, Alma will provide a User Deletion Management screen that 

identifies the reasons.  
a. If you choose to View User, you will be taken to the edit user screen. 
b. If you choose to Waive Fees, you will get another screen where you confirm deletion. 
c. If you choose to Notify User, Alma will send the User Deletion Letter, and the record is 

retained. 

Deleting a user manually removes their data fully from both Alma and Analytics. No statistical data are 
retained. 

User Purge Job 
Deleting users via purge job allows better statistical tracking, if desired. When selected the purge job 
anonymizes the user data of identifying information; only general categorizing data, such as user group 
and statistical notes, are retained. User record has a life cycle of Deleted. 

Alma’s purge job will remove any user record that has a Purge Date that is prior to the date that you run 
the job, adjusting for the Number of Days after Purge Date that you enter. Records with no purge date 
listed should not be deleted. You may wish to review the results of CARLI’s shared “Users that have 
purge dates in the past” prior to running the job.  

1. Go to Admin > User Management > Purge User Record. 
2. Click Add Job. 
3. Enter a value for Number of Days after Purge Date. Records with a purge date older than the 

difference will be purged. 
4. Select whether to purge records of all types, public users only, or staff users only (i.e., the staff 

record type; the presence of staff roles does not block deletion). 
5. Select whether to limit the job to a specific user group. 
6. Enter an amount of fines/fees owed that may be waived in order to delete the user. A user with 

a balance higher than this amount will not be deleted. 
7. Click Add and Close. 

You will receive an email notification when the job completes.  
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Deleting Locations & other Configuration Details 
Please don’t deleted locations or configuration details without reviewing the Alma documentation 
thoroughly, and ideally consulting with CARLI staff. Alma allows some settings to be deleted more easily 
than Voyager did. However, just because you can, doesn’t mean that you should. 
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